Top > PHP5.5.22にZIP拡張モジュールをインストール

ECCUBE3になってから必須なの?

ECCUBE3をサーバ内にインストールする事になり、PHPの拡張モジュールであるZIP拡張モジュールを必要に迫られインストールすることになったので取りあえずメモ。

[root@documentroot ~]# pecl install zip

これでインストール完了。

ただし、久々にpeclコマンドなんて使ったもんだから、ソースをアップデートしろと怒られる。
その対処法としては下記のようにする。

[root@documentroot ~]# pecl list-all app
[root@documentroot ~]# pecl channel-update pecl.php.net

これでpeclのデータベースが最新になるのであろう。

話は元に戻り、 pecl install zipインストールし成功すると下記のような文面が出てくる。

Build process completed successfully
Installing '/usr/lib/php5/zip.so'
install ok: channel://pecl.php.net/zip-1.13.1
configuration option "php_ini" is not set to php.ini location
You should add "extension=zip.so" to php.ini

php.iniに

extension=zip.so

と記述しapacheを再起動させ反映させる。



リロード   新規 編集 凍結 差分 添付 複製 名前変更   ホーム 一覧 単語検索 最終更新 バックアップ リンク元   ヘルプ   最終更新のRSS
Last-modified: 2015-12-04 (金) 13:06:34 (1420d)